Book pages allow horizontal scrolling on mobile

Description of your request or bug report:

On mobile, loading a book page sets an initial zoom such that it’s possible to scroll horizontally, even though there is no additional content horizontally. This is annoying because it makes it harder to scroll (swipe) the page vertically since it’s possible to scroll horizontally by accident. It is possible to zoom out (pinch to zoom on iPhone) to remove the horizontal scrolling, further proving that there is no additional horizontal content. However, this has to be done ever time a book page is loaded, which is a hassle.

Trello link:

I can not reproduce on my phone.

Can you share a screenshot?

I’m using an iPhone 8, in case that’s relevant.

Note for this picture, I had to tap-hold the screen to keep it in this scrolled view. If I let go it would (mostly) go back to normal. But the point is, it shouldn’t be possible to make the screen/page do that at all.

2 Likes

It might be the result of an old browser version. I tried both Safari and Firefox and they don’t do that.

I’m unsure of what version is used in iphone 8, if you can say what does output this website, I’m sure it will help @brandon :

I’m only a few weeks out of date for iOS, so I’m on latest or near-latest version of Safari. Also, iPhone uses the same rendering engine regardless of browser, so Safari vs Firefox, etc. shouldn’t matter.

The link you gave simply days I’m on Safari 15.5 since I’m on iOS 15.5.

2 Likes

I’m just trying to look for reproduction.

I have to force it with two fingers to the side to get something similar, but then again that behaviour I get, I get it on every page.

Other pages with same mobile view behaviour:

That said I’ll escalate it to Brandon anyway, maybe he has some idea of how it happens and how to deal with it.

2 Likes

Yeah that’s a different thing.

I’ve certainly seen this issue on other sites, but it’s more an exception than the rule.

1 Like

I also have an iphone 8 and I see this too. It’s incredibly frustrating. I’ve spent some time trying to figure out what is causing the overflow, but no dice. I should try to fix it at some point, ugh.

But glad to hear it’s mostly an iphone8 issue only :slight_smile:

APPROVED.

@Megumin really appreciate you diving into that and trying to reproduce. You’re right too the browser version & OS version usually helps, although for this particular bug, i’ve known about it for a while now (through multiple ios updates unfortunately, ugh).

3 Likes

Makes you wonder if it’s because the rendering engine is compiled differently for that particular iphone model.

But if you have an iphone 8 too, then perfect tool for reproducing the issue!

Not sure if this might help, but do you have your phone set to request Desktop site? Or “Use reader automatically”?

Mine always defaults to mobile site (I’m on iPhone 11, most recent iOS) and my desktop site request and use reader automatically show as off and I’ve never had this issue. However I did have this issue previously on other sites until I switched the settings over to request mobile site.

The AA button brings this up and mine always has the “request desktop site showing because it defaults to looking at the mobile site. The settings just above open onto the next image:

I had to change both of these settings a while back to stop the issue happening with other sites before I joined Natively. I don’t get any horizontal scrolling options unless I switch to desktop now or I purposely zoom in.

2 Likes

Even with those two settings on and one on and the other off I can not reproduce, so I think it might be something else.

1 Like

No worries, I just know it was an issue I did have a while back on other sites and changing these fixed it at that time. Wasn’t sure if it might fix it or not.

3 Likes

I have it set to mobile view, but thanks for the suggestion.

3 Likes