Grading not available depending on how book is marked 'finished'

Description of your request or bug report:

I’ve been working my way through 두루책방 - Free (series) | L0-19 and I noticed that my ability to grade finished items depends on the way they were marked as read.

If I choose ‘finished’ from the pop-up, I’m able to grade the item right away and there’s the option to grade extra. (I did this for books 1-5)

If I choose ‘open additional options’ and set as finished, I’m completely unable to grade the item - even if I refresh the page, I still get the 'Why can’t I grade this item?" rather than the grade button, and the alert doesn’t appear in the profile drop-down. (I did this for books 6-10)

I tried alternating the methods just to confirm, and the behaviour is consistent. I haven’t noticed this happening with other books, but it’s not something I paid much attention to; it was just by chance I happened to switch the way I marked books as read partway through this series.

Trello link:

When you say ‘grading is not available’… does that mean you never get prompted to grade it, even after you mark another book finished?

Yeah, it’s like it hasn’t been read at all, even though it’s marked as finished. I can’t grade the books directly when I use the ‘additional options’ method, and they don’t appear in any other comparisons.


Huh. Very interesting and definitely good info for my investigation.

There’s some strange things afoot!


Related: I just realised that if I rate/review an item, it automatically marks it as finished today, but the grading button isn’t visible until I refresh the page.


After rating/review:

After refresh:

If I mark as ‘finished’ using the pop-up, the grading button appears right away.

1 Like

This one’s slightly different in that I was able to grade it about 45 times (although it says 13), but there should be at least another 50 comparisons available judging from the other books I’m doing extra grading for: 아빠가 그려준 코끼리 | L3

eta: This one does appear in other book comparisons, I just can’t grade it directly.

1 Like

@bibliothecary can you tell me the next time you hit this issue? Particularly, when you mark finished via the ‘additional options’ and you cannot grade the item? I can’t seem to replicate the issue.


Edit: So after exploring this more, I did find some data issues that would prevent some objects going into grading. Basically, I have a ‘more gradings available’ status tracker on each user’s books. If it doesn’t have that tracker, then it doesn’t enter grading.

It looks like for korean users, since i’ve been messing around with series a bit more (triggering a switch to a variant series can cause this issue, like we did for 두루책방 can cause this), you all had quite a few books in this state.

Regardless, I’ve found them and fixed them. I’ll also be running a daily process to double check for this issue and fix it.

Now, while that issue explains some of your problems, it doesn’t necessarily explain the difference in behavior you’re seeing wrt how you mark finished. I haven’t been able to replicate that issue yet, so still exploring!

1 Like

I can now grade the 두루책방 books that I couldn’t before, but only from the item page - they don’t show up on the dashboard or profile drop-down.

download (1)

Just marked 화산과 지진 | L15 as read using additional options, and I can’t grade it:

I’ve noticed this before, but as you can see above, it’s showing that it was finished 6 hours ago instead of a few seconds ago. The activity feed often shows the ‘finished’ activity prior to the final episodes watched:

How about now?

Ok! Was able to reproduce and should now be fixed! Shouldn’t encounter this in the future.

That’s intriguing, but probably not going to handle now… can log if you’d like. Maybe all those little activity time & display issues could be one request? I think I will close this now!

1 Like