Honto account set up?

I tried setting up a Honto account online for access to buy free ebooks that I can’t get anywhere else (either in e-book format or physical format) but can’t get past the sign up page.

It won’t accept my name in English or Katakana nor will it accept anything for my date of birth after the year, there are no options for month or day to be selected.

I’ve tried using my e-mail, Line ID, google account and Facebook but every one comes back with the same error saying it timed out no matter how quickly I complete it (there’s also the parts it won’t allow me to add in my date of birth either).

Does anyone know how to fix this or should I give it up as a lost cause?

I would get Kobo instead but I can’t set that up without a local address :sweat_smile:

I have a honto account from ages ago, but I think I vaguely remember that it had 2 name fields… 1 that accepted any script including romaji, so my name was fine and the second that needed katakana (or maybe hiragana?) for the phonetic sound of the name. I didn’t have any issue with signing up back then with an Austrian address and credit card, etc. but they might have changed something. could you maybe post a screenshot of the error message you receive, if you receive any? and the form you need to fill in? (without doxxing yourself of course ;))


Yeah, my honto account is so old I set it up when they were still BK1. But FWIW in my account info my 氏名 is my name in full-width alphabet characters, in the ふりがな box I literally wrote “ふりがな”, and my postal address is my UK postal address but I also had to put a 郵便番号 of 000-0000 and say it was in 東京都.

Maybe try with a different web browser in case it’s a bug in the website and it doesn’t like whatever you’re using?


I managed to solve it accidentally and I’ve no idea how :sweat_smile:

Not sure why but, when I’ve went back through the registration link they sent me to try to get screen shots, the boxes for month and day in the date of birth section have just appeared. They weren’t there before at all. The address section is no where to be found now though (not that that’s a major issue if I’m only getting e-books).

I’ve just typed the full date of birth and it’s registered me.


Glad you got it to work. Sometimes browsers or ad-blocks don’t play nicely.


Me too, I was at it for about 2 hours before I asked on here just before going to sleep and then it fixed over night.

Next problem is my iPhone and iPad don’t allow me to get the app and the website doesn’t let me use the viewer to read :joy: I can always try reading it on my android if I can power it up but I kinda gave up after that :rofl::rofl:

Is it a region lock thing?
If Apple hasn’t changed how things work you can create a new Apple ID whose region is Japan and that should let you download from that app store. Android requires you to have a credit card from the country you’re trying to register in so if they’ve changed that on iOS then no dice.

1 Like

The apple app store issue is a region lock thing but tbh at this point it’s too much hassle to make a second apple id for my device just to download one app for one book and have to switch between ids (there may be more books in the future but atm it’s just the one I cannot get anywhere else). It’s a decent work around though so I will keep it in mind for later.

The android thing was just that I would try using the browser on that device to read the book since my apple devices weren’t allowing access.

The web browser issue though, I’ve no idea what that issue was, it just wouldn’t allow me to open it and wouldn’t allow me to translate the web page that popped up to see what it said, and I stupidly didn’t take a screenshot again. I really should learn and take screenshots so I can check it later.

It now seems to give me access for a short while then boots me back to the main screen with no pop up error or such so not sure what’s wrong now. I do have a similar issue with that on the CD Japan web site when trying to remove stuff from my basket or bookmark list so wondering if this issue is more a device/ os issue than individual site issue, as I rarely use the web browser except for a few things or for quick look ups. Most of my stuff is through other apps (amazon shopping/ music apps, YouTube app, Netflix app etc).

I’ve kinda given up at this stage but will revisit it after the next update and see if the issue still persists.

1 Like