👷 🚧 Infrastructure Overhaul! Report newly broken functionality here! 🔥 🚒

OK!! I think i figured out what was going on! Those intermittent crazy long requests should now be gone. I think the general speed should be much better too, however the search page still may take 2 seconds on initial load. Will work to improve that.

Otherwise it’s feeling pretty speedy and back to normal I think? Let me know what you all think.

Hmmm. Was that a consistent error when you hit it? Like you tried to filter again and it popped up?

I haven’t seen that one yet, but i’ll keep it in mind! I couldn’t reproduce it, so maybe another strange intermittent one, grr.

8 Likes

Care to share what the issue was? I’m always curious about the technical details.

For me it was. It happened every time I did it at that moment (at least several times). But when I tried the next day the problem was gone. This was several weeks ago for me.

6 Likes

Essentially, for frequent queries and requests, I store the response in a cache. Then, on the next request, I query the cache to see if I have it already.

Unfortunately, the cache I use (Redis) is single threaded, meaning that if you have one slow cache query, it will block all other users until it’s finished. There were a few bad cache query through intermittent async processes… so it was hard to catch but they were occurring every minute :sweat_smile:.

These queries lead to a queue being formed which caused issues. As you might imagine though, determining first that this intermittent issue was a result of the cache system and then determining that the cache slowdown was due to a query, rather than networking / memory constraints / other hardware issues was a head scratcher.

Glad I finally got it though :joy:

11 Likes

Yes, and I’m still seeing the error, but the issue is actually the use of the Enter key. It’s fine when I click the tags with the mouse, but if I hit Enter, then the error shows up. Happens regardless of which tags and how many tags. Error occurs in Firefox & Chrome

4 Likes

It’s definitely much better now - thx!!

1 Like

@brandon The custom tag overflows the dialog box:

Also, sometimes, when I’m adding tags to my Owned books, the Sort re-sorts the books and shouldn’t. For example, I’m sorting by Author (Asc) and added a custom tag to 司書正 巻一 | L29??. Originally it was sorted below my テルマエ・ロマエ | L34 grouped series, but after adding the tag it got shifted up to sit below 漫画「天官賜福」日本語翻訳版 第1巻 | L24??. Removing the tag does not re-sort the book again.

It happens for other books as well, but it’s sporadic; I’m not sure what the common factor is.

5 Likes

Somehow it auto-logout’d on both my Android and Windows today. (Firefox both.)


Did Natively mess up profile images in each book’s Activity?

2 Likes

Me as well. I suspect that happened to everyone - very occasionally sort of update or refresh will cause that. Edit: Product Updates & Casual Natively Discussion - #2532 by brandon

Looks like it’s showing the book cover instead of profile pic. Same thing happens for me as well

2 Likes

When I use Safari’s ‚Go back to previous page‘ button to return from the forum to LN, now I.e. since your change today dark mode gets lost. Edit: seems to have been fixed while writing this :wink:

1 Like

Spoiler blur isn’t working on individual video/book pages.

example:

on my profile’s reviews tab, the spoiler blur is working! So there’s that.

3 Likes

Seems to work for me

1 Like

Do you mean that the blur works for you when you apply it or that my review is properly blurred when you open the link?

Spoiler blur works for me in forums and when i view a review through my profile’s reviews tab, but not when I look at the link I posted above. then nothing is blurred and the closing text “/Spoiler” is visible.

I’m all elbows when it comes to computers so I don’t discount my screwing something up …

1 Like

@HopeWaterfall @nopenopenope

The spoiler tags have been broken for me for months. I think someone said it was Firefox specific?

3 Likes

They’re working for me on Chrome. I believe @cat’s right, it seems like it’s a Firefox issue. (Unless you’re not on Firefox, nopenopenope?)

5 Likes

Yeah, firefox. Thanks, all! I’ll go back to reading feeling far less guilty.

5 Likes

I’m on Chrome, and everything works for me, including when I click on that link. So yeah, probably a firefox specific issue.

4 Likes

I reported the bug to Firefox. Let’s see what comes out of it.

Edit: they could reproduce the bug, and it’s now an official bug report. So maybe they will actually do something about it.

10 Likes

Somehow it never occurred to me to do that - good call!

1 Like

Aaaand once again book creation is broken, this time for Japanese :sob: @brandon Could you maybe look into this? I get „Issues with our servers“ …

1 Like

Thanks for the report - looking into it!